"make_path" is not exported by the File::Path module

This error is a dog's arse. It seems to bite people who are trying to build certain packages from source on Debian lenny. That is the circumstance in which it bit me.

It is not too hard to find out that the cause is the File::Path perl module being out of date. Apparently it needs to be 2.07 or greater. Apparently also the version in Debian lenny is earlier than that.

Unfortunately that is the point at which the problem, far from getting easier, begins to encourage such behaviours as bashing the head against the wall. This is because of a collection of cunts:

This combination of circumstances tends to have undesirable consequences, like running round in circles screaming "How the pissing fuck am I supposed to find out what needs to be upgraded to make this cuntarsing shite work?"

To which the answer now is: read this web page, and so discover that there is an Ubuntu package containing just that one module, which does have a sensible package version number, which drops straight in with dpkg -i on Debian lenny, and which solves the problem. That package is libfile-path-perl 2.08-1 from Ubuntu precise.

The above link is to the package page on packages.ubuntu.com; this will probably disappear in time, and the time will be long enough that I will probably forget I've linked to it, so here are copies of the files on this website:

.deb: libfile-path-perl_2.08-1_all.deb
Source: libfile-path-perl_2.08-1.dsc libfile-path-perl_2.08-1.diff.gz libfile-path-perl_2.08.orig.tar.gz

The nuclear missiles will not hit the spaceship.

Back to Pigeon's Nest

Be kind to pigeons

Valid HTML 4.01!